Can I Select My Own PHP Configuration?

Your account has access toPHP Selector so you can choose between different PHP versions from 4.4 to 7.3. You also have the ability to select various PHP modules if required and adjust your PHP limits in terms of memory, execution time & more.

My Site Currently Runs Very Slowly, Can You Help?

Slow sites can cause issues with Google Search Ranking (SEO), Customer Retention, Sales and your own customer expectations. We run the LiteSpeed Web Server and include access to the WordPress Cache Plugin (LSCWP). This enables your WordPress and Woo Commerce Sites to...